Vintage Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7,671 Posts
Discussion Starter #1
I'm working on a car where the fuse blades/holders/springy-thingys-that-hold-the-fuses are corroded and generally FUBAR!

I've seen the replacement parts in catalogs and I've read posts where someone has replaced them.... I can't find them anywhere! Can anyone help me out???
 

·
Registered
Joined
·
21,274 Posts
Art, you may not want to see how they "repaired" it ::

IMO, I'd replaced the whole harness with either a good used one or a quality repro. I bought a repro engine gauge harness from NPD. It was excellent quality and looked like a factory item. Chances are, the rest of the harness is shot with dried out insulation, ect.
 

·
Registered
Joined
·
7,671 Posts
Discussion Starter #3
I'd replaced the whole harness with either a good used one or a quality repro.

This car was involved in a severe dash fire, the original harness is a mass of melted insulation and corroded copper strands... I have a used harness, repro harness isn't made for a 67 XR-7...
 

·
Registered
Joined
·
616 Posts
Seems like it may be a canidate for "Painless Wiring!" I believe that is what Laurie used on "Trouble."
 

·
Registered
Joined
·
6,911 Posts
maybe treating the contacts with oxisolv would work?
 

·
Registered
Joined
·
6,782 Posts
THe terminal contacts on my car were pretty filthy (corroded) when I tore mine apart three years ago. I believe I cleaned them up with some crokus cloth. Maybe a fingernail file. It took some time, IIRC...

If you aren't interested in leaving the vehicle stock, you may want to check out painless wiring's website. I would suspect they could provide a much more servicable solution for your needs...
 

·
Just some guy
67 coupe, 69 Sportsroof, 86 hatchback
Joined
·
21,252 Posts
I'm willing to bet they are beyond repair. I believe the shorts master Midlife has/had the answer
fuse clip thread
 
1 - 8 of 8 Posts
Top