Vintage Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
553 Posts
Discussion Starter #1
Last night my speedometer went crazy and would bounce from 45mph to 120mph. Very annoying. Today I pulled the gauge cluster and pulled the speedo cable from the tranny and pulled the core and lubed it up with white lithium grease.

I was reassembling everything when I noticed the bolt thing that holds the cable housing to the back of the speedometer was broke. The flange part of the bolt was broken clean off. So basically I could pull the bolt/grommet from the end of the speedo cable. Obviously the source of a lot of my speedo problems since tightening the bolt down does nothing... I can pull the cable in and out with the bolt in place... LOL. Sorry I have no pictures but what is this part called? I suppose I will have to order it. In the NPD catalog there is a part called "RETAINER, Speedo Case Grommet" $3.97... sounds like what I need, but not 100% sure.
 

·
Registered
Joined
·
3,595 Posts
Call NPD and ask them. They are very patient at explaining a part that may otherwise be known to most of us as a "little bolt thingy". :)
 

·
Registered
Joined
·
745 Posts
it sounds like the end of the speedometer cable housing end broke off or pulled apart.When you buy a speedo cable assembly,it includes this. Dave
 

·
Registered
Joined
·
553 Posts
Discussion Starter #4
oh yeah... DUH... I'm such a moron. Even if that is the right part there would be no way to slip it back over the cable when the bolt has the flange on it. I'd have to pull the metal end of the cable off then slip the new grommet on, then replace the metal end. Oh well looks like I'll have to rig it up... good thing I don't plan on selling this car, I feel when of those dorky PO wtf? was he thinking fixes coming on. :p
 
1 - 5 of 5 Posts
Top